enable menu editing di shutter ubuntu 20.04 , error E: Unable to locate package libgoocanvas-common

Bismillah ..

shutter merupakan tool screenshot yang simple tapi menyediakan menu editing sederhana yang menurut saya power full namun menu editing tidak otomatis aktif ketika install awal, butuh beberapa paket tambahan yang butuh di install yaitu libgoocanvas-common dan lain nya , namun di ubuntu 20.04 libcoocanvas nya adalah libgoocanvas 2.0

[email protected]:/home/bit# apt install libgoocanvas-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libgoocanvas-common
[email protected]:/home/bit# apt install libgoocanvas-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libgoocanvas-common
[email protected]:/home/bit# apt install libgoocanvas3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libgoocanvas3
[email protected]:/home/bit#

search package libgoocanvas menggunakan apt search nama paket nya

[email protected]:/home/bit# apt search libgoocanva
Sorting... Done
Full Text Search... Done
libgoocanvas-2.0-9/focal,now 2.0.4-1 amd64 [installed]
  Canvas widget for GTK+ - shared library

libgoocanvas-2.0-common/focal,focal,now 2.0.4-1 all [installed]
  Canvas widget for GTK+ - common files

libgoocanvas-2.0-dev/focal 2.0.4-1 amd64
  Canvas widget for GTK+ - development files

libgoocanvas2-perl/focal,focal,now 0.06-1 all [installed]
  Perl bindings for the goocanvas-2.0 widget using Glib::Object::Introspection

libgoocanvasmm-2.0-6/focal 1.90.11-3build1 amd64
  C++ bindings for GooCanvas - shared library

libgoocanvasmm-2.0-dev/focal 1.90.11-3build1 amd64
  C++ bindings for GooCanvas - development files

libgoocanvasmm-2.0-doc/focal,focal 1.90.11-3build1 all
  C++ bindings for GooCanvas - documentation and examples

[email protected]:/home/bit#

kemudian install libgoocanvas-2.0-common, libgoocanvas-2.0-9 dan libgoocanvas2-perl

[email protected]:/home/bit# apt install libgoocanvas-2.0-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libqmobipocket2 libspectre1 qtspeech5-flite-plugin
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  libgoocanvas-2.0-common
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 116 kB of archives.
After this operation, 1.723 kB of additional disk space will be used.
Get:1 http://id.archive.ubuntu.com/ubuntu focal/universe amd64 libgoocanvas-2.0-common all 2.0.4-1 [116 kB]
Fetched 116 kB in 2s (54,0 kB/s)                  
Selecting previously unselected package libgoocanvas-2.0-common.
(Reading database ... 204946 files and directories currently installed.)
Preparing to unpack .../libgoocanvas-2.0-common_2.0.4-1_all.deb ...
Unpacking libgoocanvas-2.0-common (2.0.4-1) ...
Setting up libgoocanvas-2.0-common (2.0.4-1) ...
[email protected]:/home/bit# apt install libgoocanvas-2.0-9
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libqmobipocket2 libspectre1 qtspeech5-flite-plugin
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  libgoocanvas-2.0-9
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 98,1 kB of archives.
After this operation, 315 kB of additional disk space will be used.
Get:1 http://id.archive.ubuntu.com/ubuntu focal/universe amd64 libgoocanvas-2.0-9 amd64 2.0.4-1 [98,1 kB]
Fetched 98,1 kB in 2s (62,8 kB/s)             
Selecting previously unselected package libgoocanvas-2.0-9:amd64.
(Reading database ... 205014 files and directories currently installed.)
Preparing to unpack .../libgoocanvas-2.0-9_2.0.4-1_amd64.deb ...
Unpacking libgoocanvas-2.0-9:amd64 (2.0.4-1) ...
Setting up libgoocanvas-2.0-9:amd64 (2.0.4-1) ...
Processing triggers for libc-bin (2.31-0ubuntu9.1) ...
[email protected]:/home/bit# apt install libgoocanvas2-perl
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libqmobipocket2 libspectre1 qtspeech5-flite-plugin
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  gir1.2-goocanvas-2.0 libcairo-gobject-perl libcairo-perl libdpkg-perl libextutils-depends-perl libextutils-pkgconfig-perl
  libfile-fcntllock-perl libglib-object-introspection-perl libglib-perl libgtk3-perl pkg-config
Suggested packages:
  libfont-freetype-perl debian-keyring gcc | c-compiler patch git bzr libxml-libxml-perl dpkg-dev
The following NEW packages will be installed:
  gir1.2-goocanvas-2.0 libcairo-gobject-perl libcairo-perl libdpkg-perl libextutils-depends-perl libextutils-pkgconfig-perl
  libfile-fcntllock-perl libglib-object-introspection-perl libglib-perl libgoocanvas2-perl libgtk3-perl pkg-config
0 upgraded, 12 newly installed, 0 to remove and 0 not upgraded.
Need to get 878 kB of archives.
After this operation, 4.472 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://id.archive.ubuntu.com/ubuntu focal/universe amd64 gir1.2-goocanvas-2.0 amd64 2.0.4-1 [14,1 kB]
Get:2 http://id.archive.ubuntu.com/ubuntu focal/main amd64 libextutils-depends-perl all 0.8000-1 [15,0 kB]
Get:3 http://id.archive.ubuntu.com/ubuntu focal/main amd64 libdpkg-perl all 1.19.7ubuntu3 [230 kB]
Get:4 http://id.archive.ubuntu.com/ubuntu focal/main amd64 pkg-config amd64 0.29.1-0ubuntu4 [45,5 kB]                        
Get:5 http://id.archive.ubuntu.com/ubuntu focal/main amd64 libextutils-pkgconfig-perl all 1.16-1 [9.260 B]                   
Get:6 http://id.archive.ubuntu.com/ubuntu focal/main amd64 libcairo-perl amd64 1.107-1 [87,9 kB]                             
Get:7 http://id.archive.ubuntu.com/ubuntu focal/main amd64 libglib-perl amd64 3:1.329.2-1 [331 kB]                           
Get:8 http://id.archive.ubuntu.com/ubuntu focal/main amd64 libcairo-gobject-perl amd64 1.005-2 [11,8 kB]                     
Get:9 http://id.archive.ubuntu.com/ubuntu focal/main amd64 libfile-fcntllock-perl amd64 0.22-3build4 [33,1 kB]               
Get:10 http://id.archive.ubuntu.com/ubuntu focal/main amd64 libglib-object-introspection-perl amd64 0.048-2build1 [63,2 kB]  
Get:11 http://id.archive.ubuntu.com/ubuntu focal/main amd64 libgtk3-perl all 0.037-1 [29,2 kB]                               
Get:12 http://id.archive.ubuntu.com/ubuntu focal/universe amd64 libgoocanvas2-perl all 0.06-1 [7.928 B]                      
Fetched 878 kB in 9s (103 kB/s)                                                                                              
Selecting previously unselected package gir1.2-goocanvas-2.0:amd64.
(Reading database ... 205019 files and directories currently installed.)
Preparing to unpack .../00-gir1.2-goocanvas-2.0_2.0.4-1_amd64.deb ...
Unpacking gir1.2-goocanvas-2.0:amd64 (2.0.4-1) ...
Selecting previously unselected package libextutils-depends-perl.
Preparing to unpack .../01-libextutils-depends-perl_0.8000-1_all.deb ...
Unpacking libextutils-depends-perl (0.8000-1) ...
Selecting previously unselected package libdpkg-perl.
Preparing to unpack .../02-libdpkg-perl_1.19.7ubuntu3_all.deb ...
Unpacking libdpkg-perl (1.19.7ubuntu3) ...
Selecting previously unselected package pkg-config.
Preparing to unpack .../03-pkg-config_0.29.1-0ubuntu4_amd64.deb ...
Unpacking pkg-config (0.29.1-0ubuntu4) ...
Selecting previously unselected package libextutils-pkgconfig-perl.
Preparing to unpack .../04-libextutils-pkgconfig-perl_1.16-1_all.deb ...
Unpacking libextutils-pkgconfig-perl (1.16-1) ...
Selecting previously unselected package libcairo-perl.
Preparing to unpack .../05-libcairo-perl_1.107-1_amd64.deb ...
Unpacking libcairo-perl (1.107-1) ...
Selecting previously unselected package libglib-perl:amd64.
Preparing to unpack .../06-libglib-perl_3%3a1.329.2-1_amd64.deb ...
Unpacking libglib-perl:amd64 (3:1.329.2-1) ...
Selecting previously unselected package libcairo-gobject-perl.
Preparing to unpack .../07-libcairo-gobject-perl_1.005-2_amd64.deb ...
Unpacking libcairo-gobject-perl (1.005-2) ...
Selecting previously unselected package libfile-fcntllock-perl.
Preparing to unpack .../08-libfile-fcntllock-perl_0.22-3build4_amd64.deb ...
Unpacking libfile-fcntllock-perl (0.22-3build4) ...
Selecting previously unselected package libglib-object-introspection-perl.
Preparing to unpack .../09-libglib-object-introspection-perl_0.048-2build1_amd64.deb ...
Unpacking libglib-object-introspection-perl (0.048-2build1) ...
Selecting previously unselected package libgtk3-perl.
Preparing to unpack .../10-libgtk3-perl_0.037-1_all.deb ...
Unpacking libgtk3-perl (0.037-1) ...
Selecting previously unselected package libgoocanvas2-perl.
Preparing to unpack .../11-libgoocanvas2-perl_0.06-1_all.deb ...
Unpacking libgoocanvas2-perl (0.06-1) ...
Setting up libfile-fcntllock-perl (0.22-3build4) ...
Setting up gir1.2-goocanvas-2.0:amd64 (2.0.4-1) ...
Setting up libextutils-depends-perl (0.8000-1) ...
Setting up libdpkg-perl (1.19.7ubuntu3) ...
Setting up pkg-config (0.29.1-0ubuntu4) ...
Setting up libextutils-pkgconfig-perl (1.16-1) ...
Setting up libcairo-perl (1.107-1) ...
Setting up libglib-perl:amd64 (3:1.329.2-1) ...
Setting up libcairo-gobject-perl (1.005-2) ...
Setting up libglib-object-introspection-perl (0.048-2build1) ...
Setting up libgtk3-perl (0.037-1) ...
Setting up libgoocanvas2-perl (0.06-1) ...
Processing triggers for man-db (2.9.1-1) ...
[email protected]:/home/bit#

close aplikasi nya atau gunakan perintah ” sudo killall shutter” kemudia buka lagi

selamat mencoba semoga , bermanfaat 🙂

referensi :

https://itsfoss.com/shutter-edit-button-disabled/

No Comments, Be The First!

Your email address will not be published.

Time limit is exhausted. Please reload CAPTCHA.