Otomatis Back up Mikrotik Lewat SMTP

Bismillah,…

Insyaallah hari ini saya akan menjelaskan bagai mana kita melakukan back up dari Mikrotik Router kita secara otomatis lewat SMTP , dalam hal ini saya menggunakan Gmail , jadi syarat pertama kita harus punya account gmail dan tentunya sebuah Mikrotik RB atau Mikrotik RouterOs terinstall di PC ,

baik, secara garis besar  proses back up akan di lakukan dengan sebuah script, script tersebut berisi comand melakukan proses backup ,di sertai tanggal dan board name yang kemudian akan di kirim dengan email SMTP Gmail  kemudian menghapus back up dari disk mikrotik supaya meng hindari Disk Mikrotik RB penuh

OK langsung saja, pertama baca bismillah dulu , kemudian kita akan seting tools email di mikrotik terlebuh dahulu ,

buka progam winbox kesayangan kita , dan menuju ke /tools e-mail

sesuaikan dengan gambar berikut (gunankan account e-mail masing-masing) kemudian bisa lakukan test send email

MK1

kemudian kita create sebuah script, berikut script nya:

:local a [/system identity get name];
 :local b [/system clock get time]    <------ Memberikan waktu pada file backup
 :set b ([:pick $b 0 0].[:pick $b 3 5].[:pick $b 6 8])
 :local c [/system clock get date] <------- memeberikan tanggal pada file backup
 :set c ([:pick $c 7 11].[:pick $c 0 3].[:pick $c 4 6])
 :local d [/system resource get board-name]; <---- memberikan nama board file backup
 :local backupm ($a.$b.$c.$d)
 /system backup save name=$backupm;
 :delay 30s
 :log info "sedang mengirim email, tunggu beberapa detik.."
 /tool e-mail send subject=$backupm [email protected] [email protected] start-tls=yes file=$backupm
 :log info "Email sudah terkirim bro..."
 :delay 90s
 /file find name=$backupm
 /file remove $backupm
 :log info "$backupm telah di hapus..!"

MK2

 

kemudian kita bisa buat scheduler  /system scheduler

MK3

isikan On Event dengan nama script yang telah kita buat tadi

setelah scrpit kita eksekusi  , hasil nya kurang lebih akan sperti ini

Mk4

log proses scrpit

MK5

Backup telah sampai dengan selamat , Alhamdulillah

yah, silakan di coba  , beberapa referensi sya dapat di google , jadi sumber referensi sya sya cari dengan mengetikan key word ” Back up Mkrotik secara otomatis” dan “backup Mikrotik melalui email ” serta ” mengirim email dari mikrotik”.

No Comments, Be The First!

Your email address will not be published.

Time limit is exhausted. Please reload CAPTCHA.