Otomatis Update Nice IIX IP Address list Di Mikrotik

Bismillah ,

Nice address list atau file nice.rsc adalah Fileyang dibuat secara otomatis di server Mikrotik Indonesia setiap jam, dan merupakan data yang telah dioptimalkan untuk menghilangkan duplikasi entri dan tumpang tindih subnet. berisi daftar ip daftar IP Address yang diadvertise di OpenIXP dan IIX

salah satu fungsi dari nice ini adalah untuk pemisahan bandwith antara trafik lokal atau IX dan internasional atau IIX,

ok ,sepertibiasa kita akan melakukan prose update ini melalui sebuah script yang nantinya akan di eksekusi berdasarkan scheduller yang akan di tentukan  yang kemudian script ini juga akan melalukan konfirmasi melalui e-mail bahwa update telah berhasil, sehinggga kita bisa mengetahui jika terjadi error pada saat proses update.

pertama kita seting smtp mikrotik untuk konfirmasi email ketika update berhasil , langkah nya bisa di lihat di sini

kemudian kita buat script di /system script ,

berikut script update nice.rsc nya:

:if ([:len [/file find name=nice.rsc]] > 0) do={/file remove nice.rsc};
 :log info "file nice.rsc telah di hapus bro...!"
 :delay 30s
 :log info "download newest nice file , tunggu sebentar bro...."
 /tool fetch address=ixp.mikrotik.co.id src-path=/download/nice.rsc mode=http;
 /import nice.rsc
 :delay 10s
 /tool e-mail send subject=update-nice [email protected] [email protected] [email protected] body=alhamdulillah-nice-berhasil-di-update start-tls=yes

Selection_023

sesuaikan alamat email pengirim dan yang dituju

kemudian buat scheduller untuk meng eksekusi script tersebut,

kemudian coba kita test script di atas dan berikut proses script nya

Selection_024 log script

Selection_025 nice addresslist hasil update

Selection_026 email konfirmasi

beberapa tips :

– jika log tidak muncul , kita bisa melakukan troubleshooting dengan memisah kan bagian-bagian script dan coba kita eksekusi manual lewat terminal mikrotik karena sejati nya sript diatas adalah console comand mikrotik.

– pada bagian body email(isi email) tidak boleh menggunakan sepasi , bisa di test di terminal mikrotik

sumber referensi: http://mikrotik.co.id/artikel_lihat.php?id=23 ,

 

No Comments, Be The First!

Your email address will not be published.

Time limit is exhausted. Please reload CAPTCHA.